woaidongmao

文章均收录自他人博客,但不喜标题前加-[转贴],因其丑陋,见谅!~
随笔 - 1469, 文章 - 0, 评论 - 661, 引用 - 0
数据加载中……

关于active控件cab包自动根据版本进行更新安装的问题

把active控件打成cab包后,用户安装了这个active控件,如果服务器端升级了active控件,更新了版本号,用户在打开包含active的网页后,能否自动提示发现高版本,然后进行安装?

====================================================================

可以

====================================================================

会提示要安装控件.   (假设你的控件已经做数字签名了)
另外,你更新的DLL需要更新文件的版本号,还有在打包的ocx文件的inf文件中要更新版本号.
最后在那个codebase里的 "#version= "后面更新成新的版本号.(好像需要和INF文件中的要保持一致)
完成上面的步骤,如果IE的权限设置正常的话再次访问更新后的页面会提示要安装控件的.

posted on 2008-06-16 18:41 肥仔 阅读(1423) 评论(0)  编辑 收藏 引用 所属分类: 网络编程


只有注册用户登录后才能发表评论。
【推荐】超50万行VC++源码: 大型组态工控、电力仿真CAD与GIS源码库
网站导航: 博客园   IT新闻   BlogJava   知识库   博问   管理