ACM___________________________

______________白白の屋
posts - 182, comments - 102, trackbacks - 0, articles - 0

MiYu原创, 转帖请注明 : 转载自 ______________白白の屋    

 

题目地址 :
    http://acm.hdu.edu.cn/showproblem.php?pid=1017

题目描述:

A Mathematical Curiosity

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8614    Accepted Submission(s): 2592


Problem Description
Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.
 

Input
You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.
 

Output
For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.
 

Sample Input
1 10 1 20 3 30 4 0 0
 

Sample Output
Case 1: 2 Case 2: 4 Case 3: 5
 

 

 题目分析 :

  没事水一水, 嘿嘿.......   新手只需要 注意下输出就可以了 . 暴力过, 没什么技巧

 

代码如下 :

 /*

MiYu原创, 转帖请注明 : 转载自 ______________白白の屋

          http://www.cnblog.com/MiYu

Author By : MiYu

Test      : 1

Program   : 1017

*/


#include <iostream>

#include <algorithm>

using namespace std;

int main ()

{

    int T;    cin >> T;

    for ( int k = 1; k <= T; ++ k ){

           int N, M, ca = 1, cnt = 0;

           if ( k != 1 ) putchar ( 10 );

           while ( cin >> N >> M, N || M ){     cnt = 0;

                  for ( int i = 1; i < N; ++ i ){

                       for ( int j = i + 1; j < N; ++ j ){

                            if ( ( i * i + j * j + M ) % ( i * j ) == 0 )    

                                 cnt ++;

                       }    

                  }   

                  printf ( "Case %d: %d\n",ca++, cnt );   

           }      

    } 

    return 0;

}


 

 

 


只有注册用户登录后才能发表评论。
网站导航: 博客园   IT新闻   BlogJava   知识库   博问   管理