ACM___________________________

______________白白の屋
posts - 182, comments - 102, trackbacks - 0, articles - 0

MiYu原创, 转帖请注明 : 转载自 ______________白白の屋    

 

题目地址:

     http://acm.hdu.edu.cn/showproblem.php?pid=2642 

题目描述:

Stars

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/65536 K (Java/Others)
Total Submission(s): 166    Accepted Submission(s): 66


Problem Description
Yifenfei is a romantic guy and he likes to count the stars in the sky.
To make the problem easier,we considerate the sky is a two-dimension plane.Sometimes the star will be bright and sometimes the star will be dim.At first,there is no bright star in the sky,then some information will be given as "B x y" where 'B' represent bright and x represent the X coordinate and y represent the Y coordinate means the star at (x,y) is bright,And the 'D' in "D x y" mean the star at(x,y) is dim.When get a query as "Q X1 X2 Y1 Y2",you should tell Yifenfei how many bright stars there are in the region correspond X1,X2,Y1,Y2.

There is only one case.
 

Input
The first line contain a M(M <= 100000), then M line followed.
each line start with a operational character.
if the character is B or D,then two integer X,Y (0 <=X,Y<= 1000)followed.
if the character is Q then four integer X1,X2,Y1,Y2(0 <=X1,X2,Y1,Y2<= 1000) followed.
 

Output
For each query,output the number of bright stars in one line.
 

Sample Input
5 B 581 145 B 581 145 Q 0 600 0 200 D 581 145 Q 0 600 0 200
 

Sample Output
1 0
 

 

题目分析 :

 与 HDU 1892 基本相同的一道题,  只是矩阵数组的值被限定在 [0,1] ,   是一道 二维 树状数组的 裸题,  直接 模板, 加上对题目数据做一些

处理即可.

 

代码如下 :

/*
MiYu原创, 转帖请注明 : 转载自 ______________白白の屋
          http://www.cnblog.com/MiYu
Author By : MiYu
Test      : 1
Program   : 2642
*/

#include <iostream>
#include <algorithm>
using namespace std;
#define lowbit(x) (x&(-x))
int T;
const int MAX = 1001;
int mat[1002][1002];
int com[1002][1002];
void modify ( int x,int y, int n )
{
     while ( x <= MAX ){
           int t = y;
           while ( t <= MAX ){
                  com[x][t] += n;
                  t += lowbit(t); 
           } 
           x += lowbit(x);
     } 
}
int quy ( int x, int y )
{
     int sum = 0;
     while ( x > 0 ){
           int t = y;
           while ( t > 0 ){
                  sum += com[x][t];
                  t ^= lowbit(t); 
           } 
           x ^= lowbit(x);
     } 
     return sum; 
}
inline bool scan_d(int &num) 
{
        char in;bool IsN=false;
        in=getchar();
        if(in==EOF) return false;
        while(in!='-'&&(in<'0'||in>'9')) in=getchar();
        if(in=='-'){ IsN=true;num=0;}
        else num=in-'0';
        while(in=getchar(),in>='0'&&in<='9'){
                num*=10,num+=in-'0';
        }
        if(IsN) num=-num;
        return true;
}
int main ()
{
      while ( scan_d(T) ) {
            int ca = 1;
                   char s[5];  int a,b,x,y,m,res,maxx,maxy,minx,miny;
                   memset ( com, 0, sizeof ( com ) );
                   while ( T -- ) {
                         scanf ( "%s",s );
                         switch ( s[0] ){
                                case 'Q' : scan_d(a);scan_d(x);scan_d(b);scan_d(y); minx = min ( a,x );miny=min(b,y);maxx=max(a,x)+1;maxy=max(b,y)+1;
                                           res = 0;  res += quy( maxx,maxy ); res -= quy (maxx,miny); res -= quy(minx,maxy); res += quy(minx,miny);
                                           printf ( "%d\n",res ); break;   
                                case 'B' : scan_d(x);scan_d(y); x++;y++; if ( !mat[x][y] ) { modify ( x,y,1 ); mat[x][y] = 1; } break;
                                case 'D' : scan_d(x);scan_d(y); x++;y++; if ( mat[x][y] ) { modify ( x,y,-1 ); mat[x][y] = 0; } break;  
                         } 
                   }
    }
    return 0;
}

 

 


只有注册用户登录后才能发表评论。
网站导航: 博客园   IT新闻   BlogJava   知识库   博问   管理