随笔-145  评论-173  文章-70  trackbacks-0
今天在使用Mercurial同步版本库的时候,出现错误:

warning: code.google.com certificate with fingerprint ed:2e:18:55:ee:6b:cc:4c:cb:8b:11:a8:74:5c:97:9e:1d:42:b5:be not verified (check hostfingerprints or web.cacerts config setting)
destination directory: ipv6-hosts
abort: Operation not permitted: /media/Code/ipv6-hosts/ipv6-hosts/.hg/requires
半天死活找不到原因,记得在Git下面checkout Google Code项目的时候并没有出现类似的提示,由于以前没有接触过Mercurial,因此花了点时间Google一下,最终发现大致的过程也不过如此,init, checkout,pull等等。

但是回到正题,不论是init还是clone都会出现上面的错误,提示权限问题,抱着试试的态度,使用sudo命名,记过成功的init和clone,看来不论是哪里,都要注意权限。

不过额外再说一点,同样的,我在该目录下面新建一个文件夹,利用git init来初始化的时候,却并没有碰到相同的问题,只能说明,Git和Mercurial的机制可能不同,后者在操作的过程中需要加入提升权限的口令。记录一下,由于使用Mercurial的机会也不是很多,这里只是拷贝一下版本库,并无太多深入研究,所以先记录在这里吧。
posted on 2012-04-07 21:29 deercoder 阅读(660) 评论(0)  编辑 收藏 引用 所属分类: Unix/LinuxGit

只有注册用户登录后才能发表评论。
【推荐】超50万行VC++源码: 大型组态工控、电力仿真CAD与GIS源码库
网站导航: 博客园   IT新闻   BlogJava   知识库   博问   管理