coreBugZJ

此 blog 已弃。

The kth great number, The 36th ACM/ICPC Asia Regional Dalian Site —— Online Contest

The kth great number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)

Problem Description
Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.
 

Input
There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a "Q", then you need to output the kth great number. 
 

Output
The output consists of one integer representing the largest number of islands that all lie on one line. 
 

Sample Input
8 3
I 1
I 2
I 3
Q
I 5
Q
I 4
Q
 

Sample Output
1
2
3

Hint
Xiao Ming won't ask Xiao Bao the kth great number when the number of the written number is smaller than k. (1=<k<=n<=1000000).
 


打个酱油。
小根堆保存最多 K 个元素,对每次询问输出堆顶元素。



 1 #include <iostream>
 2 #include <cstdio>
 3 #include <algorithm>
 4 #include <queue>
 5 
 6 using namespace std;
 7 
 8 typedef  priority_queue< int, vector< int >, greater< int > >  Heap;
 9 
10 int main() {
11         Heap mh;
12         int n, k, x;
13         char cmd[ 3 ];
14         while ( 2 == scanf( "%d%d"&n, &k ) ) {
15                 while ( ! mh.empty() ) {
16                         mh.pop();
17                 }
18                 while ( n-- > 0 ) {
19                         scanf( "%s", cmd );
20                         if ( 'I' == cmd[ 0 ] ) {
21                                 scanf( "%d"&x );
22                                 mh.push( x );
23                                 while ( mh.size() > k ) {
24                                         mh.pop();
25                                 }
26                         }
27                         else {
28                                 printf( "%d\n", mh.top() );
29                         }
30                 }
31         }
32         return 0;
33 }
34 

posted on 2011-09-03 18:17 coreBugZJ 阅读(348) 评论(0)  编辑 收藏 引用 所属分类: ACM


只有注册用户登录后才能发表评论。
网站导航: 博客园   IT新闻   BlogJava   知识库   博问   管理