随笔 - 550, 文章 - 0, 评论 - 921, 引用 - 0
数据加载中……

关于阻止迅雷上传,带慢计算机的工具

一直用迅雷,下载速度都挺不错.
最近,用了一个性能比较差的计算机.发现迅雷老在上传东西.整个硬盘体力跨啦的,计算机性能超级差.

于是写了个工具.阻止其上传.
工具在这里 http://alantop.5166.info/software.html

源码如下:

.版本 2
.支持库 shell

.程序集 窗口程序集1

.子程序 _按钮1_被单击
.局部变量 存在, 逻辑型
.局部变量 文件属性, 整数型

 

存在 = 文件是否存在 (文件名)
.如果 (存在)
    是否存在.标题 = “存在”
.否则
    是否存在.标题 = “不存在”
.如果结束

文件属性 = 取文件属性 (文件名)
.如果 (位与 (文件属性, #只读文件) ≠ 0)
    是否存在.标题 = “迅雷不能上传”
.否则
    是否存在.标题 = “迅雷需要处理”
.如果结束

 


.子程序 _按钮2_被单击
.局部变量 文件号, 整数型

.如果 (删除文件 (文件名))
    是否存在.标题 = “文件删除成功”
.否则
    是否存在.标题 = “文件删除失败”
.如果结束
文件号 = 打开文件 (文件名, #重写, #无限制)
关闭文件 (文件号)
.如果 (置文件属性 (文件名, #只读文件))
    是否存在.标题 = “文件属性设置成功”
.否则
    是否存在.标题 = “文件属性设置失败”
.如果结束


.子程序 __启动窗口_创建完毕

文件名 = 取特定目录 (#Windows安装目录) + “system32\cid_store.dat”

posted on 2008-02-26 10:29 AlanTop 阅读(2743) 评论(5)  编辑 收藏 引用 所属分类: 计算机应用C++VC++

评论

# re: 关于阻止迅雷上传,带慢计算机的工具  回复  更多评论   

请问是易语言写的吧?
2008-02-26 11:27 | owlcn

# re: 关于阻止迅雷上传,带慢计算机的工具[未登录]  回复  更多评论   

是的,现在是易语言+vc dll这种方式 开发速度快!
2008-02-26 11:34 | alantop

# re: 关于阻止迅雷上传,带慢计算机的工具  回复  更多评论   

下载打开看看不就知道了`
2008-02-26 11:52 | 新魔界私服

# re: 关于阻止迅雷上传,带慢计算机的工具  回复  更多评论   

应该是结合版
2008-02-26 11:52 | 魔域私服

# re: 关于阻止迅雷上传,带慢计算机的工具  回复  更多评论   

打字不累么?
2008-03-07 08:33 | haohao

只有注册用户登录后才能发表评论。
【推荐】超50万行VC++源码: 大型组态工控、电力仿真CAD与GIS源码库
网站导航: 博客园   IT新闻   BlogJava   知识库   博问   管理