Dict.CN 在线词典, 英语学习, 在线翻译

学海苦作舟,书山勤为径

留下点回忆

常用链接

统计

积分与排名

Denoise

English study

Web技术

数据压缩

一些连接

最新评论

CentOS5.8升级glibc到2.7

由于安装OpenOffice3.4.2,提示需要Glibc2.7,然后运行yum install glibc已经yum update glibc,不过之间检查仍然是rpm -qi glibc(2.5).看来CentOS只升级到2.5了.因此不得不手动安装glibc2.7了.
这里是我安装的过程记录.
1.首先是找个目录(我找的是/root)来下在glibc2.7的源代码.
2.运行 wget http://ftp.gnu.org/pub/gnu/glibc/glibc-2.7.tar.gz来下在程序
3.下在后运行tar -xvf glibc-2.7.tar.gz来解压缩,程序会自动放到glibc-2.7目录下;为了编译方便创建一个临时目录glibc-build(这个目录与glibc-2.7同一级别)
4.进如glibc-build,并运行../glibc2.7/configure --prefix=/usr;注意后面的参数非常必要,/usr是系统安装的目录,替换系统的glibc.如果不替换,你可以设置/usr/local.
5.好了之后就可以在这个目录运行make了;make成功之后就是make install.
6.如果上面都成功了,可以重新启动shutdown -r "now"
系统重启之后,glibc-2.7已经工作了,不过rpm -qi glibc仍然是2.5(谁知道请告诉一声).

posted on 2012-08-08 16:24 笨笨 阅读(11494) 评论(1)  编辑 收藏 引用 所属分类: Linux

评论

# re: CentOS5.8升级glibc到2.7 2013-06-03 11:05 Fity

rpm -qi 查的是系统中通过包管理器安装的包,手动编译没有添加到包管理中去。具体要怎么添加,不熟。  回复  更多评论   


只有注册用户登录后才能发表评论。
【推荐】超50万行VC++源码: 大型组态工控、电力仿真CAD与GIS源码库
网站导航: 博客园   IT新闻   BlogJava   知识库   博问   管理