POJ 1157 LITTLE SHOP OF FLOWERS 动态规划

Description

You want to arrange the window of your flower shop in a most pleasant way. You have F bunches of flowers, each being of a different kind, and at least as many vases ordered in a row. The vases are glued onto the shelf and are numbered consecutively 1 through V, where V is the number of vases, from left to right so that the vase 1 is the leftmost, and the vase V is the rightmost vase. The bunches are moveable and are uniquely identified by integers between 1 and F. These id-numbers have a significance: They determine the required order of appearance of the flower bunches in the row of vases so that the bunch i must be in a vase to the left of the vase containing bunch j whenever i < j. Suppose, for example, you have bunch of azaleas (id-number=1), a bunch of begonias (id-number=2) and a bunch of carnations (id-number=3). Now, all the bunches must be put into the vases keeping their id-numbers in order. The bunch of azaleas must be in a vase to the left of begonias, and the bunch of begonias must be in a vase to the left of carnations. If there are more vases than bunches of flowers then the excess will be left empty. A vase can hold only one bunch of flowers.

Each vase has a distinct characteristic (just like flowers do). Hence, putting a bunch of flowers in a vase results in a certain aesthetic value, expressed by an integer. The aesthetic values are presented in a table as shown below. Leaving a vase empty has an aesthetic value of 0.
 

V A S E S

1

2

3

4

5

Bunches

1 (azaleas)

7 23 -5 -24 16

2 (begonias)

5 21 -4 10 23

3 (carnations)

-21

5 -4 -20 20

According to the table, azaleas, for example, would look great in vase 2, but they would look awful in vase 4.

To achieve the most pleasant effect you have to maximize the sum of aesthetic values for the arrangement while keeping the required ordering of the flowers. If more than one arrangement has the maximal sum value, any one of them will be acceptable. You have to produce exactly one arrangement.

Input

  • The first line contains two numbers: F, V.
  • The following F lines: Each of these lines contains V integers, so that Aij is given as the jth number on the (i+1)st line of the input file.


  • 1 <= F <= 100 where F is the number of the bunches of flowers. The bunches are numbered 1 through F.
  • F <= V <= 100 where V is the number of vases.
  • -50 <= Aij <= 50 where Aij is the aesthetic value obtained by putting the flower bunch i into the vase j.

Output

The first line will contain the sum of aesthetic values for your arrangement.

Sample Input

3 5
7 23 -5 -24 16
5 21 -4 10 23
-21 5 -4 -20 20

Sample Output

53

Source

    因为题目中规定若i<j,则第i束花必须出现在第j束花之前,根据这一条件,可以用花的数目来进行动态规划。设dp[i,j]为前i束花插在前j个花瓶中的最大美学值,有状态转移方程:dp[i,j]=max(dp[i-1,k-1]+A[i,k]),其中i<=k<=j,A[i,k]为第i束花插在第k个花瓶中的美学值,规定dp[i,0]=0,1<=i<=F。
#include<iostream>
using namespace std;

const int MAXN = 101;
const int inf = 10000;
int A[MAXN][MAXN],dp[MAXN][MAXN];

int main(){
    
int i,j,k,f,v,t;
    
while(scanf("%d %d",&f,&v)!=EOF){
        
for(i=1;i<=f;i++){
            dp[i][
0]=0;
            
for(j=1;j<=v;j++){
                scanf(
"%d",&A[i][j]);
                dp[i][j]
=-1;
            }

        }

        
for(i=1;i<=f;i++)
            
for(j=1;j<=v;j++)
                
for(t=-inf,k=i;k<=j;k++){
                    t
=max(t,dp[i-1][k-1]+A[i][k]);
                    
if(dp[i][j]==-1 || dp[i][j]<t)
                        dp[i][j]
=t;
                }

        printf(
"%d\n",dp[f][v]);
    }

    
return 0;
}

posted on 2009-06-16 13:57 极限定律 阅读(1324) 评论(1)  编辑 收藏 引用 所属分类: ACM/ICPC

评论

# re: POJ 1157 LITTLE SHOP OF FLOWERS 动态规划 2009-11-17 21:57 Gamor

dp[i][j] = max(dp[i][j - 1], dp[i - 1][j - 1] + A[i][j])  回复  更多评论   


只有注册用户登录后才能发表评论。
网站导航: 博客园   IT新闻   BlogJava   知识库   博问   管理


<2024年4月>
31123456
78910111213
14151617181920
21222324252627
2829301234
567891011

导航

统计

常用链接

留言簿(10)

随笔分类

随笔档案

友情链接

搜索

最新评论

阅读排行榜

评论排行榜