ZOJ 1276 Optimal Array Multiplication Sequence 经典DP问题

Given two arrays A and B, we can determine the array C = A B using the standard definition of matrix multiplication:

 

The number of columns in the A array must be the same as the number of rows in the B array. Notationally, let's say that rows(A) and columns(A) are the number of rows and columns, respectively, in the A array. The number of individual multiplications required to compute the entire C array (which will have the same number of rows as A and the same number of columns as B) is then rows(A) columns(B) columns(A). For example, if A is a 10 x 20 array, and B is a 20 x 15 array, it will take 10 x 15 x 20, or 3000 multiplications to compute the C array.


To perform multiplication of more than two arrays we have a choice of how to proceed. For example, if X, Y, and Z are arrays, then to compute X Y Z we could either compute (X Y) Z or X (Y Z). Suppose X is a 5 x 10 array, Y is a 10 x 20 array, and Z is a 20 x 35 array. Let's look at the number of multiplications required to compute the product using the two different sequences:

 

(X Y) Z


5 x 20 x 10 = 1000 multiplications to determine the product (X Y), a 5 x 20 array.

Then 5 x 35 x 20 = 3500 multiplications to determine the final result.

Total multiplications: 4500.

X (Y Z)

10 x 35 x 20 = 7000 multiplications to determine the product (Y Z), a 10 x 35 array.

Then 5 x 35 x 10 = 1750 multiplications to determine the final result.

Total multiplications: 8750.

Clearly we'll be able to compute (X Y) Z using fewer individual multiplications.

Given the size of each array in a sequence of arrays to be multiplied, you are to determine an optimal computational sequence. Optimality, for this problem, is relative to the number of individual multiplcations required.


Input

For each array in the multiple sequences of arrays to be multiplied you will be given only the dimensions of the array. Each sequence will consist of an integer N which indicates the number of arrays to be multiplied, and then N pairs of integers, each pair giving the number of rows and columns in an array; the order in which the dimensions are given is the same as the order in which the arrays are to be multiplied. A value of zero for N indicates the end of the input. N will be no larger than 10.


Output

Assume the arrays are named A1, A2, ..., AN. Your output for each input case is to be a line containing a parenthesized expression clearly indicating the order in which the arrays are to be multiplied. Prefix the output for each case with the case number (they are sequentially numbered, starting with 1). Your output should strongly resemble that shown in the samples shown below. If, by chance, there are multiple correct sequences, any of these will be accepted as a valid answer.


Sample Input

3
1 5
5 20
20 1
3
5 10
10 20
20 35
6
30 35
35 15
15 5
5 10
10 20
20 25
0


Sample Output

Case 1: (A1 x (A2 x A3))
Case 2: ((A1 x A2) x A3)
Case 3: ((A1 x (A2 x A3)) x ((A4 x A5) x A6))


Source: North Central North America 1996
    

    设计算矩阵A[i:j],1<=i<=j<=n,所需要的最少乘法次数为m[i,j],则原问题的最优值为m[1,n]。
    当i=j时,A[i:j]=Ai,m[i,i]=0,i=1,2,...,n;
    当i<j时,m[i,j]=m[i,k]+m[k+1][j]+pi-1*pk*pj,i<=k<j。
#include<iostream>
using namespace std;

void MatrixChain(int n,int p[],int m[][11],int s[][11]){
    
int i,j,k,r,t;
    
for(i=1;i<=n;i++) m[i][i]=0;
    
for(r=2;r<=n;r++)
        
for(i=1;i<=n-r+1;i++){
            j
=i+r-1;
            m[i][j]
=m[i+1][j]+p[i-1]*p[i]*p[j];
            s[i][j]
=i;
            
for(k=i+1;k<j;k++){
                t
=m[i][k]+m[k+1][j]+p[i-1]*p[k]*p[j];
                
if(t<m[i][j]){
                    m[i][j]
=t;
                    s[i][j]
=k;
                }

            }

        }

}

void output(int i,int j,int s[][11]){
    
if(i==j)
        printf(
"A%d",i);
    
else{
        printf(
"(");
        output(i,s[i][j],s);
        printf(
" x ");
        output(s[i][j]
+1,j,s);
        printf(
")");
    }

}

int main(){
    
int i,n,ca=1,p[11],m[11][11],s[11][11];
    
while(scanf("%d",&n),n){
        
for(i=1;i<=n;i++) scanf("%d %d",&p[i-1],&p[i]);
        MatrixChain(n,p,m,s);
        printf(
"Case %d: ",ca++);
        output(
1,n,s);
        printf(
"\n");
    }

    
return 0;
}

posted on 2009-06-19 09:27 极限定律 阅读(1088) 评论(0)  编辑 收藏 引用 所属分类: ACM/ICPC


只有注册用户登录后才能发表评论。
网站导航: 博客园   IT新闻   BlogJava   知识库   博问   管理


<2009年6月>
31123456
78910111213
14151617181920
21222324252627
2829301234
567891011

导航

统计

常用链接

留言簿(10)

随笔分类

随笔档案

友情链接

搜索

最新评论

阅读排行榜

评论排行榜