POJ 2195 Going Home 二分图完美匹配

Description

On a grid map there are n little men and n houses. In each unit time, every little man can move one unit step, either horizontally, or vertically, to an adjacent point. For each little man, you need to pay a $1 travel fee for every step he moves, until he enters a house. The task is complicated with the restriction that each house can accommodate only one little man.

Your task is to compute the minimum amount of money you need to pay in order to send these n little men into those n different houses. The input is a map of the scenario, a '.' means an empty space, an 'H' represents a house on that point, and am 'm' indicates there is a little man on that point.

You can think of each point on the grid map as a quite large square, so it can hold n little men at the same time; also, it is okay if a little man steps on a grid with a house without entering that house.

Input

There are one or more test cases in the input. Each case starts with a line giving two integers N and M, where N is the number of rows of the map, and M is the number of columns. The rest of the input will be N lines describing the map. You may assume both N and M are between 2 and 100, inclusive. There will be the same number of 'H's and 'm's on the map; and there will be at most 100 houses. Input will terminate with 0 0 for N and M.

Output

For each test case, output one line with the single integer, which is the minimum amount, in dollars, you need to pay.

Sample Input

2 2
.m
H.
5 5
HH..m
.....
.....
.....
mm..H
7 8
...H....
...H....
...H....
mmmHmmmm
...H....
...H....
...H....
0 0

Sample Output

2
10
28

Source


    题目大意:有m个人要进h间房子,从当前位置(x1,y1)进入房子(x2,y2)的时间为|x1-x2|+|y1-y2|,问这m个人都进入房间所需的最小时间是多少。问题可以转化为带权二分图的最小权匹配,以sample 2为例先建立二分图:
 
(m1,h1)=4,(m1,h2)=3,(m1,h3)=4,(m2,h1)=4,(m2,h2)=5,(m2,h3)=4,(m3,h1)=5,(m3,h2)=4,(m3,h3)=3.
然后用KM算法求解,代码中的注释部分为最大权匹配。
#include <iostream>

const int MAX = 101;
const int MAXN = 10001;
const int inf = 0x7FFFFFFF;
struct point{
    
int x,y;
}
man[MAXN],home[MAXN];
bool vx[MAX],vy[MAX];
int m,h,map[MAX][MAXN],lx[MAX],ly[MAX],match[MAX];

bool dfs(int u){
    
int i;
    
for(vx[u]=true,i=0;i<h;i++)
        
if(!vy[i] && lx[u]+ly[i]==map[u][i]){
            vy[i]
=true;
            
if(match[i]==-1 || dfs(match[i])){
                match[i]
=u;
                
return true;
            }

        }

    
return false;
}

int kuhn_munkras(){
    
int i,j,k,min,ans;
    
for(i=0;i<m;i++)
        
for(lx[i]=inf,j=0;j<h;j++)
            
if(map[i][j]<lx[i]) lx[i]=map[i][j];
  
//for(i=0;i<m;i++)
  
//    for(lx[i]=-inf,j=0;j<h;j++)
  
//        if(map[i][j]>lx[i]) lx[i]=map[i][j]; 最大权匹配
    for(i=0;i<h;i++) ly[i]=0;
    memset(match,
-1,sizeof(match));
    
for(i=0;i<m;i++){
        
while(true){
            memset(vx,
false,sizeof(vx));
            memset(vy,
false,sizeof(vy));
            min
=inf;
            
if(dfs(i)) break;
            
for(j=0;j<m;j++){
                
if(vx[j]){
                    
for(k=0;k<h;k++)
                        
if(!vy[k] && map[j][k]-lx[j]-ly[k]<min)
                            min
=map[j][k]-lx[j]-ly[k];
                      
//if(!vy[k] && lx[j]+ly[k]-map[j][k]<min)
                      
//    min=map[j][k]-lx[j]-ly[k]; 最大权匹配
                }

            }

            
for(j=0;j<m;j++if(vx[j]) lx[j]+=min;
            
for(j=0;j<h;j++if(vy[j]) ly[j]-=min;
        }

    }

    
for(ans=i=0;i<h;i++) ans+=map[match[i]][i];
    
return ans;
}

int main(){
    
char ch;
    
int i,j,row,colum;
    
while(scanf("%d %d",&row,&colum),row||colum){
        
for(getchar(),m=h=i=0;i<row;i++){
            
for(j=0;j<colum;j++){
                ch
=getchar();
                
if(ch=='m')
                    man[m].x
=i,man[m].y=j,m++;
                
else if(ch=='H')
                    home[h].x
=i,home[h].y=j,h++;
            }

            getchar();
        }

        memset(map,
0,sizeof(map));
        
for(i=0;i<m;i++)
            
for(j=0;j<h;j++)
                map[i][j]
=abs(man[i].x-home[j].x)+abs(man[i].y-home[j].y);
        printf(
"%d\n",kuhn_munkras());
    }

    
return 0;
}

posted on 2009-06-03 12:45 极限定律 阅读(776) 评论(0)  编辑 收藏 引用 所属分类: ACM/ICPC


只有注册用户登录后才能发表评论。
网站导航: 博客园   IT新闻   BlogJava   知识库   博问   管理


<2009年6月>
31123456
78910111213
14151617181920
21222324252627
2829301234
567891011

导航

统计

常用链接

留言簿(10)

随笔分类

随笔档案

友情链接

搜索

最新评论

阅读排行榜

评论排行榜