POJ 3692 Kindergarten 二分图最大独立集

Description

In a kindergarten, there are a lot of kids. All girls of the kids know each other and all boys also know each other. In addition to that, some girls and boys know each other. Now the teachers want to pick some kids to play a game, which need that all players know each other. You are to help to find maximum number of kids the teacher can pick.

Input

The input consists of multiple test cases. Each test case starts with a line containing three integers
G, B (1 ≤ G, B ≤ 200) and M (0 ≤ MG × B), which is the number of girls, the number of boys and
the number of pairs of girl and boy who know each other, respectively.
Each of the following M lines contains two integers X and Y (1 ≤ X≤ G,1 ≤ Y ≤ B), which indicates that girl X and boy Y know each other.
The girls are numbered from 1 to G and the boys are numbered from 1 to B.

The last test case is followed by a line containing three zeros.

Output

For each test case, print a line containing the test case number( beginning with 1) followed by a integer which is the maximum number of kids the teacher can pick.

Sample Input

2 3 3
1 1
1 2
2 3
2 3 5
1 1
1 2
2 1
2 2
2 3
0 0 0

Sample Output

Case 1: 3
Case 2: 4

Source


     

本题是要求图中的最大完全子图(最大团)中顶点的个数。由于原图的补图是一个二分图,其最大完全数等价于其补图的最大独立集中元素的个数,于是可以根据二分图的性质求出这个最大独立集。而普通图的最大团则是一个NP问题。

定理:二分图最大独立集=顶点数-二分图最大匹配

最大完全数:图中最大完全子图的顶点个数。

独立集:图中任意两个顶点都不相连的顶点集合。

#include <iostream>
using namespace std;

const int MAXN = 201;
bool visit[MAXN];
int n,m,k,mark[MAXN];
bool map[MAXN][MAXN];

bool dfs(int u){
    
int i;
    
for(i=1;i<=m;i++)
        
if(map[u][i] && !visit[i]){
            visit[i]
=true;
            
if(mark[i]==-1 || dfs(mark[i])){
                mark[i]
=u;
                
return true;
            }

        }

    
return false;
}

int hungary(){
    
int i,ans=0;
    
for(i=1;i<=n;i++){
        memset(visit,
false,sizeof(visit));
        
if(dfs(i)) ans++;
    }

    
return ans;
}

int main(){
    
int i,j,x,y,id=1;
    
while(scanf("%d %d %d",&n,&m,&k),n||m||k){
        
for(i=1;i<=n;i++for(j=1;j<=m;j++) map[i][j]=true;
        
while(k--){
            scanf(
"%d %d",&x,&y);
            map[x][y]
=false;
        }

        memset(mark,
-1,sizeof(mark));
        printf(
"Case %d: %d\n",id++,n+m-hungary());
    }

    
return 0;
}

posted on 2009-06-02 15:14 极限定律 阅读(2033) 评论(0)  编辑 收藏 引用 所属分类: ACM/ICPC


只有注册用户登录后才能发表评论。
网站导航: 博客园   IT新闻   BlogJava   知识库   博问   管理


<2009年6月>
31123456
78910111213
14151617181920
21222324252627
2829301234
567891011

导航

统计

常用链接

留言簿(10)

随笔分类

随笔档案

友情链接

搜索

最新评论

阅读排行榜

评论排行榜