HDOJ 1016 Prime Ring Problem

Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
6
8
 

Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4
Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2
    素数环:由1到n个数构成一个环,其中环内任意2个相邻的数字之和是素数。
    比较经典的搜索题,由于n<20,可以先预处理出前40个自然数中的素数,然后深搜某个位置的未被访问过的数字和它相邻位置的数字之和是否为素数,搜索退出的条件为最后一个位置的数字circle[n]+1是否为素数。一次搜索完成后,要回溯,否则只会输出一组解。
#include <iostream>
using namespace std;

const int MAXN = 41;
bool visit[MAXN];
int n,p[MAXN],circle[MAXN];

void prime(){
    
int i,j;
    memset(p,
true,sizeof(p));
    
for(i=2;i<MAXN;i++)
        
for(j=2;i*j<MAXN;j++)
            p[i
*j]=false;
}

void dfs(int c,int cnt){
    
if(cnt==&& p[circle[1]+circle[n]]){
        
for(int i=1;i<n;i++)
            printf(
"%d ",circle[i]);
        printf(
"%d\n",circle[n]);
    }

    
for(int i=c+1;i<MAXN;i++)
        
if(p[i] && i-c<=&& !visit[i-c]){
            circle[cnt
+1]=i-c;
            visit[i
-c]=true;
            dfs(i
-c,cnt+1);
            visit[i
-c]=false;
        }

}

int main(){
    
int c=1;
    prime();
    
while(scanf("%d",&n)!=EOF){
        memset(visit,
false,sizeof(visit));
        printf(
"Case %d:\n",c++);
        visit[
1]=true,circle[1]=1;
        dfs(
1,1);
        printf(
"\n");
    }

    
return 0;
}

posted on 2009-05-24 13:37 极限定律 阅读(1137) 评论(1)  编辑 收藏 引用 所属分类: ACM/ICPC

评论

# re: HDOJ 1016 Prime Ring Problem 2009-08-04 09:53

谢了 !!!!!!!!!!1  回复  更多评论   


只有注册用户登录后才能发表评论。
网站导航: 博客园   IT新闻   BlogJava   知识库   博问   管理


<2009年5月>
262728293012
3456789
10111213141516
17181920212223
24252627282930
31123456

导航

统计

常用链接

留言簿(10)

随笔分类

随笔档案

友情链接

搜索

最新评论

阅读排行榜

评论排行榜