HDOJ 1698 Just A Hook 线段树

Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.



Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.
 

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
 

Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
 

Sample Input
1
10
2
1 5 2
5 9 3
 

Sample Output
Case 1: The total value of the hook is 24.
 

Source

#include <iostream>
using namespace std;

const int MAXN = 100001;
struct segment{
    
int left,right,color;
    
bool cover;
}
tree[MAXN*3];

void create(int l,int r,int step){
    tree[step].left
=l,tree[step].right=r;
    tree[step].color
=tree[step].cover=1;
    
if(l==r) return ;
    
int mid=(l+r)>>1;
    create(l,mid,
2*step);
    create(mid
+1,r,2*step+1);
}

void update(int l,int r,int c,int step){
    
if(l==tree[step].left&&r==tree[step].right){
        tree[step].color
=c;
        tree[step].cover
=1;
        
return;
    }

    
if(tree[step].cover){
        tree[step].cover
=0;
        tree[
2*step].cover=tree[2*step+1].cover=1;
        tree[
2*step].color=tree[2*step+1].color=tree[step].color;
    }

    
if(r<=tree[2*step].right)
        update(l,r,c,
2*step);
    
else if(l>=tree[2*step+1].left)
        update(l,r,c,
2*step+1);
    
else{
        update(l,tree[
2*step].right,c,2*step);
        update(tree[
2*step+1].left,r,c,2*step+1);
    }

}

int query(int step){
    
if(tree[step].cover) 
        
return tree[step].color*(tree[step].right-tree[step].left+1);
    
else 
        
return query(2*step)+query(2*step+1);
}

int main(){
    
int i,t,n,q,l,r,c;
    scanf(
"%d",&t);
    
for(i=1;i<=t;i++){
        scanf(
"%d %d",&n,&q);
        create(
1,n,1);
        
while(q--){
            scanf(
"%d %d %d",&l,&r,&c);
            update(l,r,c,
1);
        }

        printf(
"Case %d: The total value of the hook is %d.\n",i,query(1));
    }

    
return 0;
}

posted on 2009-05-12 16:32 极限定律 阅读(490) 评论(1)  编辑 收藏 引用 所属分类: ACM/ICPC

评论

# re: HDOJ 1698 Just A Hook 线段树 2009-08-13 21:02 zeus

good 刚刚做了也是1y
呵呵你写什么都很详细啊 学习了  回复  更多评论   


只有注册用户登录后才能发表评论。
网站导航: 博客园   IT新闻   BlogJava   知识库   博问   管理


<2009年5月>
262728293012
3456789
10111213141516
17181920212223
24252627282930
31123456

导航

统计

常用链接

留言簿(10)

随笔分类

随笔档案

友情链接

搜索

最新评论

阅读排行榜

评论排行榜