POJ 1151 Atlantis 离散化+扫描线

Problem Description
There are several ancient Greek texts that contain descriptions of the fabled island Atlantis. Some of these texts even include maps of parts of the island. But unfortunately, these maps describe different regions of Atlantis. Your friend Bill has to know the total area for which maps exist. You (unwisely) volunteered to write a program that calculates this quantity.
 

Input
The input file consists of several test cases. Each test case starts with a line containing a single integer n (1<=n<=100) of available maps. The n following lines describe one map each. Each of these lines contains four numbers x1;y1;x2;y2 (0<=x1<x2<=100000;0<=y1<y2<=100000), not necessarily integers. The values (x1; y1) and (x2;y2) are the coordinates of the top-left resp. bottom-right corner of the mapped area.

The input file is terminated by a line containing a single 0. Don’t process it.
 

Output
For each test case, your program should output one section. The first line of each section must be “Test case #k”, where k is the number of the test case (starting with 1). The second one must be “Total explored area: a”, where a is the total explored area (i.e. the area of the union of all rectangles in this test case), printed exact to two digits to the right of the decimal point.

Output a blank line after each test case.
 

Sample Input
2
10 10 20 20
15 15 25 25.5
0
 

Sample Output
Test case #1
Total explored area: 180.00 
    题目的意思是给定n个矩形的2n个坐标,求矩形的覆盖面积。如果开一个大的bool数组,将覆盖过的部分更新为true,再从头到尾扫描一遍,在坐标范围比较小的情况下,可以求解。但是如果坐标x,y的取值范围很大,比如[-10^8,10^8],用上面这个方法就不能求解了;而且坐标还有可能是实数,上面的方法就更加不可行了,需要寻找一种新的解法,就是下面要说到的“离散化”。
    注意到要表示一个矩形,只需要知道其2个顶点的坐标就可以了(最左下,最右上)。可以用2个数组x[0...2n-1],y[0...2n-1]记录下矩形Ri的2个坐标(x1,y1),(x2,y2),然后将数组x[0...xn-1],y[0...2n-1]排序,为下一步的扫描线作准备,这就是离散化的思想。这题还可以用线段树做进一步优化,但是这里只介绍离散化的思想。
    看下面这个例子:有2个矩形(1,1),(3,3)和(2,2),(4,4)。如图:
    图中虚线表示扫描线,下一步工作只需要将这2个矩形覆盖过的部分的bool数组的对应位置更新为true,接下去用扫描线从左到右,从上到下扫描一遍,就可以求出矩形覆盖的总面积。
    这个图对应的bool数组的值如下:
    1 1 0                       1 2 3
    1 1 1       <---->       4 5 6
    0 1 1                       7 8 9
 1 #include <iostream>
 2 #include <cmath>
 3 using namespace std;
 4 
 5 const int N = 101;
 6 const double eps = 1e-6;
 7 double ans,x[2*N],y[2*N];
 8 double pos[N][4];
 9 bool hash[2*N][2*N];
10 
11 int cmp(const void *a,const  void *b){
12     double *aa = (double *)a;
13     double *bb = (double *)b;
14     if(fabs(*aa-*bb)<=eps) return 0;
15     else if(*aa-*bb>0return 1;
16     else return -1;
17 }
18 int main(){
19     int i,j,k,n,x1,x2,y1,y2,ca=1;
20     while(scanf("%d",&n),n){
21         for(ans=i=k=0;i<n;i++,k+=2){
22             scanf("%lf %lf %lf %lf",&pos[i][0],&pos[i][1],&pos[i][2],&pos[i][3]);
23             x[k]=pos[i][0],y[k]=pos[i][1],x[k+1]=pos[i][2],y[k+1]=pos[i][3];
24         }
25         memset(hash,false,sizeof(hash));
26         qsort(x,2*n,sizeof(x[0]),cmp);
27         qsort(y,2*n,sizeof(y[0]),cmp);
28         for(i=0;i<n;i++){
29             for(k=0;fabs(x[k]-pos[i][0])>eps;k++); x1=k;
30             for(k=0;fabs(y[k]-pos[i][1])>eps;k++); y1=k;
31             for(k=0;fabs(x[k]-pos[i][2])>eps;k++); x2=k;
32             for(k=0;fabs(y[k]-pos[i][3])>eps;k++); y2=k;
33             for(j=x1;j<x2;j++for(k=y1;k<y2;k++)
34                 hash[j][k]=true;
35         }
36         for(i=0;i<2*n-1;i++)
37             for(j=0;j<2*n-1;j++)
38                 ans+=hash[i][j]*(x[i+1]-x[i])*(y[j+1]-y[j]);            
39         printf("Test case #%d\n",ca++);
40         printf("Total explored area: %.2lf\n",ans);
41         printf("\n");
42     }
43     return 0;
44 }

posted on 2009-04-26 19:43 极限定律 阅读(697) 评论(0)  编辑 收藏 引用 所属分类: ACM/ICPC


只有注册用户登录后才能发表评论。
网站导航: 博客园   IT新闻   BlogJava   知识库   博问   管理


<2009年4月>
2930311234
567891011
12131415161718
19202122232425
262728293012
3456789

导航

统计

常用链接

留言簿(10)

随笔分类

随笔档案

友情链接

搜索

最新评论

阅读排行榜

评论排行榜