POJ 1050 To the MAX(最大子矩阵问题)

Problem Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2

is in the lower left corner:

9 2
-4 1
-1 8

and has a sum of 15.
 

Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
 

Output
Output the sum of the maximal sub-rectangle.
 

Sample Input
4
0 -2 -7 0 9 2 -6 2
-4 1 -4 1 -1
8 0 -2
 

Sample Output
15
给定一个N*N的矩阵,要求一个子矩阵,使得该矩阵的元素和最大。转为为最大连续子序列问题。
 1 #include <iostream>
 2 
 3 const int N = 101;
 4 const int inf = INT_MIN;
 5 int a[N][N],b[N];
 6 
 7 int MaxSum(int n,int a[]){
 8     int i,sum=inf,b=0;
 9     for(i=1;i<=n;i++){
10         b=(b+a[i])>a[i]?(b+a[i]):a[i];
11         sum=sum>b?sum:b;
12     }
13     return sum;
14 }
15 int main(){
16     int n,i,j,k,max,ans;
17     while(scanf("%d",&n)!=EOF){
18         for(i=1;i<=n;i++)
19             for(j=1;j<=n;j++)
20                 scanf("%d",&a[i][j]);
21         for(max=inf,i=1;i<=n;i++){
22             memset(b,0,sizeof(b));
23             for(j=i;j<=n;j++){
24                 for(k=1;k<=n;k++)
25                     b[k]+=a[j][k];
26                 ans=MaxSum(n,b);
27                 max=max>ans?max:ans;
28             }
29         }
30         printf("%d\n",max);
31     }
32     return 0;
33 }

posted on 2009-04-25 12:30 极限定律 阅读(1720) 评论(0)  编辑 收藏 引用 所属分类: ACM/ICPC


只有注册用户登录后才能发表评论。
网站导航: 博客园   IT新闻   BlogJava   知识库   博问   管理


<2009年4月>
2930311234
567891011
12131415161718
19202122232425
262728293012
3456789

导航

统计

常用链接

留言簿(10)

随笔分类

随笔档案

友情链接

搜索

最新评论

阅读排行榜

评论排行榜