随笔 - 87  文章 - 279  trackbacks - 0
<2006年10月>
24252627282930
1234567
891011121314
15161718192021
22232425262728
2930311234

潜心看书研究!

常用链接

留言簿(19)

随笔分类(81)

文章分类(89)

相册

ACM OJ

My friends

搜索

  •  

积分与排名

  • 积分 - 211919
  • 排名 - 116

最新评论

阅读排行榜

评论排行榜

解题报告:http://www.mydrs.org/program/list.asp?id=583

Bridging Signals

Time limit: 1 Seconds   Memory limit: 32768K  
Total Submit: 946   Accepted Submit: 495  

'Oh no, they've done it again', cries the chief designer at the Waferland chip factory. Once more the routing designers have screwed up completely, making the signals on the chip connecting the ports of two functional blocks cross each other all over the place. At this late stage of the process, it is too expensive to redo the routing. Instead, the engineers have to bridge the signals, using the third dimension, so that no two signals cross. However, bridging is a complicated operation, and thus it is desirable to bridge as few signals as possible. The call for a computer program that finds the maximum number of signals which may be connected on the silicon surface without crossing each other, is imminent. Bearing in mind that there may be thousands of signal ports at the boundary of a functional block, the problem asks quite a lot of the programmer. Are you up to the task?

Figure 1. To the left: The two blocks' ports and their signal mapping (4, 2, 6, 3, 1, 5). To the right: At most three signals may be routed on the silicon surface without crossing each other. The dashed signals must be bridged.

A typical situation is schematically depicted in figure 1. The ports of the two functional blocks are numbered from 1 to p, from top to bottom. The signal mapping is described by a permutation of the numbers 1 to p in the form of a list of p unique numbers in the range 1 to p, in which the ith number specifies which port on the right side should be connected to the ith port on the left side. Two signals cross if and only if the straight lines connecting the two ports of each pair do.


Input

On the first line of the input, there is a single positive integer n, telling the number of test scenarios to follow. Each test scenario begins with a line containing a single positive integer p < 40000, the number of ports on the two functional blocks. Then follow p lines, describing the signal mapping:

On the ith line is the port number of the block on the right side which should be connected to the ith port of the block on the left side.


Output

For each test scenario, output one line containing the maximum number of signals which may be routed on the silicon surface without crossing each other.


Sample Input

4
6
4
2
6
3
1
5
10
2
3
4
5
6
7
8
9
10
1
8
8
7
6
5
4
3
2
1
9
5
8
9
2
3
1
7
4
6

Sample Output

3
9
1
4

#include  < iostream>
using
  namespace std;

const   int  MAXN  =   40001;

void Solve()
{
    
int n;
    
int i, j, k;
    
int l, r, m;
    
int t;
    
int  d[MAXN]  =   { 0 };
    
int a[MAXN];
    
int  len  =   0;
    scanf(
" %d " &n);
    
for  (i = 1 ; i <= n; i ++) 
        scanf(
" %d " &a[i]);
    
for  (i = 1 ; i <= n; i ++)
    
{
        
if  (a[i]  > d[len])
        
{
            len 
+=   1;
            d[len] 
= a[i];
        }

        
else
        
{
            l 
=   1;
            r 
= len;
            
while  (l  <  r  -   1)
            
{
                m 
=  (l  +  r)  /   2;
                
if  (d[m]  < a[i])
                    l 
= m;
                else
                    r 
= m;
            }

            if
 (d[l] > a[i]) 
                d[l] 
= a[i];
            else
                d[r] 
= a[i];
        }

    }

    printf("
%d\n ", len);        
}



int main()
{
    
int caseTime;
    scanf(
" %d " &caseTime);
    
while  (caseTime --   !=   0)
    
{
        Solve();
    }

    system("pause
");
    
return  0;
}






posted on 2006-10-04 12:20 阅读(558) 评论(0)  编辑 收藏 引用 所属分类: ACM题目

只有注册用户登录后才能发表评论。
网站导航: 博客园   IT新闻   BlogJava   知识库   博问   管理