随笔 - 87  文章 - 279  trackbacks - 0
<2006年9月>
272829303112
3456789
10111213141516
17181920212223
24252627282930
1234567

潜心看书研究!

常用链接

留言簿(19)

随笔分类(81)

文章分类(89)

相册

ACM OJ

My friends

搜索

  •  

积分与排名

  • 积分 - 211931
  • 排名 - 116

最新评论

阅读排行榜

评论排行榜

Post Office
Time Limit:1000MS  Memory Limit:10000K
Total Submit:1047 Accepted:456

Description
There is a straight highway with villages alongside the highway. The highway is represented as an integer axis, and the position of each village is identified with a single integer coordinate. There are no two villages in the same position. The distance between two positions is the absolute value of the difference of their integer coordinates.

Post offices will be built in some, but not necessarily all of the villages. A village and the post office in it have the same position. For building the post offices, their positions should be chosen so that the total sum of all distances between each village and its nearest post office is minimum.

You are to write a program which, given the positions of the villages and the number of post offices, computes the least possible sum of all distances between each village and its nearest post office.

Input
Your program is to read from standard input. The first line contains two integers: the first is the number of villages V, 1 <= V <= 300, and the second is the number of post offices P, 1 <= P <= 30, P <= V. The second line contains V integers in increasing order. These V integers are the positions of the villages. For each position X it holds that 1 <= X <= 10000.

Output
The first line contains one integer S, which is the sum of all distances between each village and its nearest post office.

Sample Input

10 5
1 2 3 6 7 9 11 22 44 50

Sample Output

9

Source
IOI 2000

#include  < iostream >
using   namespace  std;

/*
p表示i到j的建一个邮局的最小值
q表示前i个地点建j个邮局的最小值 
dp方程

                 p[1][i]               (j == 1)
 q[i][j] = {                                                    }
                q[k][j-1] + p[k+1][i]  (j > 1) (k从j-1到i-1)

*/
 

int  p[ 301 ][ 301 ];
int  q[ 301 ][ 31 ];
int  a[ 301 ];

int  main()
{
    
int  V, P;
    
int  i, j, k, l;
    
int  t[ 301 ];
    
int  tmp;
    scanf(
" %d%d " & V,  & P);
    
    
for  (i = 1 ; i <= V; i ++ )
        scanf(
" %d " & a[i]);
    
    
for  (i = 1 ; i <= V; i ++ )
        
for  (j = i; j <= V; j ++ )
        
{
            
if  (i  ==  j)
                p[i][j] 
=   0 ;
            
else
            
{
                l 
=  (i  +  j)  /   2 ;
                p[i][j] 
=   0 ;
                
for  (k = i; k <= l; k ++ )
                    p[i][j] 
+=  a[l]  -  a[k];
                
for  (k = l + 1 ; k <= j; k ++ )
                    p[i][j] 
+=  a[k]  -  a[l];
               
            }

        }

        
    memset(q, 
0 sizeof (q));
    
for  (i = 1 ; i <= V; i ++ )
        
for  (j = 1 ; j <= P; j ++ )
        
{
            
if  (j  ==   1 )
                q[i][j] 
=  p[ 1 ][i];
            
else
            
{
                
if  (i  >=  j)
                
{
                    q[i][j] 
=  q[j - 1 ][j - 1 +  p[j][i];
                    
for  (k = j; k < i; k ++ )
                    
{
                        
if  (q[i][j]  >  q[k][j - 1 +  p[k + 1 ][i])
                            q[i][j] 
=  q[k][j - 1 +  p[k + 1 ][i];
                    }

                }

            }

        }

        
    cout 
<<  q[V][P]  <<  endl;
    system(
" pause " );
    
return   0 ;
}

posted on 2006-09-01 22:33 阅读(435) 评论(0)  编辑 收藏 引用 所属分类: ACM题目

只有注册用户登录后才能发表评论。
网站导航: 博客园   IT新闻   BlogJava   知识库   博问   管理