随笔 - 10  文章 - 0  trackbacks - 0
<2017年9月>
272829303112
3456789
10111213141516
17181920212223
24252627282930
1234567

常用链接

留言簿

随笔分类

随笔档案

收藏夹

调试技巧

搜索

  •  

最新评论

阅读排行榜

评论排行榜

安装步骤

1. 编译环境准备

准备一下编译环境,防止出现安装错误

 yum groupinstall 'Development Tools'  yum install zlib-devel bzip2-devel openssl-devel ncurese-devel

2. 下载python3.5代码包

这里选择下载最近版本的Python3.5.1 (2016-05)

 wget https://www.python.org/ftp/python/3.5.1/Python-3.5.1.tar.xz

3. 编译

 tar Jxvf Python-3.5.1.tar.xz  cd Python-3.5.1  ./configure --prefix=/usr/local/python3  make && make install

Python3.5.1 安装编译安装时会默认安装 pip 如果出现:
Ignoring ensurepip failure: pip 1.5.6 requires SSL/TLS
未安装编译环境,重新安装该编译环境并重新编译 Python3.5.1
yum install zlib-devel bzip2-devel openssl-devel ncurese-devel

4. 更换系统默认 Python 版本

  1. 备份旧版本 Python
    mv /usr/bin/python /usr/bin/python2.7
  2. 新建指向新版本 Python 以及 pip 的软连接
    ln -s /usr/local/python3/bin/python3.5 /usr/bin/python
    ln -s /usr/local/python3/bin/pip3 /usr/bin/pip
  3. 检验 Python 及 pip 版本
    python -V
    pip -V

5.更新 yum 相关设置

因 yum 的功能依赖 Python2 更改默认 Python版本后会导致 yum无法正常工作
执行以下命令:
vi /usr/bin/yum
打开文件,修改第一行为:
#!/usr/bin/python2.7

若执行 yum 时出现以下错误:
File "/usr/libexec/urlgrabber-ext-down", line 28
执行以下更改,打开该文件并修改首行为:
#!/usr/bin/python2.7

6. 其他

执行 yum 时,若出现以下 Error:
Error: Delta RPMs disabled because /usr/bin/applydeltarpm not installed.
执行以下安装可解决:
yum install deltarpm

版本共存

如果你希望同时使用多版本 Python ,例如在保持系统原有版本 Python2.x 不变的情况下使用 Python 3.x,可以考虑使用 virtualenv 构建合适版本的虚拟环境:

# python2.7 环境下搭建 python3.x 环境 #安装 pip yum install python-setuptools easy_install pip #安装virtualenv pip install virtualenv  #在当前文件夹下构建虚拟环境 virtualenv -p /usr/local/python3/bin/python3 venv #启动虚拟环境 source venv/bin/activate  #退出虚拟环境 deactivate

virtualenv 详细使用说明,参见 Virtualenv



作者:少年的狐先生
链接:http://www.jianshu.com/p/8bd6e0695d7f
來源:简书
著作权归作者所有。商业转载请联系作者获得授权,非商业转载请注明出处。
posted on 2017-09-12 11:33 长戟十三千 阅读(9) 评论(0)  编辑 收藏 引用 所属分类: 编程技巧随笔

只有注册用户登录后才能发表评论。
【推荐】超50万行VC++源码: 大型组态工控、电力仿真CAD与GIS源码库
网站导航: 博客园   IT新闻   BlogJava   知识库   博问   管理