voip
风的方向
厚德致远,博学敦行!
posts - 52,comments - 21,trackbacks - 0

Ignatius and the Princess III

Time Limit:1000MS  Memory Limit:65536K
Total Submit:86 Accepted:66

Description

"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+...+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"

Input

The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.

Output

For each test case, you have to output a line contains an integer P which indicate the different equations you have found.

Sample Input

4
10
20

 

Sample Output

5
42
627
      就是这个题目上次我写整数划分的时候半天也没找到。。。直接用递归会超时!!
代买如下:
#include<cstdio>
int main()
{
    
int i,j,n,c[121][121];
    
for(i=1;i<121;i++)
        
for(j=1;j<121;j++)
        
{
            
if(i==1||j==1)
                c[i][j]
=1;
            
else if(i<j)
                c[i][j]
=c[i][i];
            
else if(i==j)
                c[i][j]
=c[i][j-1]+1;
            
else
                c[i][j]
=c[i][j-1]+c[i-j][j];
        }

    
while(scanf("%d",&n)!=EOF)
    
{
        printf(
"%d\n",c[n][n]);
    }

    
return 0;
}



posted on 2010-09-19 13:59 jince 阅读(129) 评论(0)  编辑 收藏 引用 所属分类: Questions

只有注册用户登录后才能发表评论。
网站导航: 博客园   IT新闻   BlogJava   知识库   博问   管理


哈哈哈哈哈哈