socketref,再见!高德

https://github.com/adoggie

  C++博客 :: 首页 :: 联系 :: 聚合  :: 管理
  246 Posts :: 4 Stories :: 312 Comments :: 0 Trackbacks

常用链接

留言簿(54)

我参与的团队

搜索

  •  

最新评论

阅读排行榜

评论排行榜

6.x 版本系统自带python 2.6,升级2.7的方式网上有很多版本,本人试用下来觉得诸多不便。
工作项目中越来越多的开发特性必须要求工作在py2.7版本中,例如:  django 1.7+已经不支持 py2.6.x了;  pyBox2d也不支持。
这次选择的最新版本 python 2.7.11 

准备工作: 
1. 下载  python2.7.11.tar.gz ( python.org) 
2. pygame-1.9.tar.gz (pygame.org) 
3. pybox2d-2.3  (github.com/pybox2d) 

安装: 
1. 编译py2.7
     tar xvzf python2.7xx.tar.gz ; ./configure ; make ; make install  
     默认安装到/usr/local/bin/, 注意,避免2.7与系统2.6的python冲突,更名 /usr/local/bin/python,或者直接删除  

2. 安装SDL
     yum install SDL_*

3. 安装 virtualenv 
    pip install virtualenv
    virtualenv -p /usr/local/bin/python2.7 ~/python2.7
    source ~/python2.7/bin/active      #进入虚拟环境
 
4. 安装 pygame,box2d 
    tar xvzf pygame_xx.tar.gz; python setup.py install 
    tar xvzf pybox2d_xx.tar.gz; python setup.py install 

5. 配置Pycharm开发环境 
    pycharm支持virtualenv,
  [File] -> [Settings]->[Project Interpreter] ->[ Create Virtual] 
posted on 2016-01-29 14:17 放屁阿狗 阅读(8730) 评论(0)  编辑 收藏 引用 所属分类: Python

只有注册用户登录后才能发表评论。
【推荐】超50万行VC++源码: 大型组态工控、电力仿真CAD与GIS源码库
网站导航: 博客园   IT新闻   BlogJava   知识库   博问   管理