技术,瞎侃,健康,休闲……

mahu@cppblog 人类的全部才能无非是时间和耐心的混合物
posts - 11, comments - 13, trackbacks - 0, articles - 12
  C++博客 :: 首页 :: 新随笔 :: 联系 :: 聚合  :: 管理

The 3n + 1 problem

Posted on 2006-06-10 00:41 mahudu@cppblog 阅读(1273) 评论(3)  编辑 收藏 引用 所属分类: C/C++

Background

Problems in Computer Science are often classified as belonging to a certain class of problems (e.g., NP, Unsolvable, Recursive). In this problem you will be analyzing a property of an algorithm whose classification is not known for all possible inputs.

The Problem

Consider the following algorithm:

1.	input n

2. print n

3. if n = 1 then STOP

4. if n is odd then tex2html_wrap_inline44

5. else tex2html_wrap_inline46

6. GOTO 2

Given the input 22, the following sequence of numbers will be printed 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1

It is conjectured that the algorithm above will terminate (when a 1 is printed) for any integral input value. Despite the simplicity of the algorithm, it is unknown whether this conjecture is true. It has been verified, however, for all integers n such that 0 < n < 1,000,000 (and, in fact, for many more numbers than this.)

Given an input n, it is possible to determine the number of numbers printed (including the 1). For a given n this is called the cycle-length of n. In the example above, the cycle length of 22 is 16.

For any two numbers i and j you are to determine the maximum cycle length over all numbers between i and j.

The Input

The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 1,000,000 and greater than 0.

You should process all pairs of integers and for each pair determine the maximum cycle length over all integers between and including i and j.

You can assume that no opperation overflows a 32-bit integer.

The Output

For each pair of input integers i and j you should output i, j, and the maximum cycle length for integers between and including i and j. These three numbers should be separated by at least one space with all three numbers on one line and with one line of output for each line of input. The integers i and j must appear in the output in the same order in which they appeared in the input and should be followed by the maximum cycle length (on the same line).

Sample Input

1 10
100 200
201 210
900 1000

Sample Output

1 10 20
100 200 125
201 210 89
900 1000 174

Solution  

#include <iostream>

using namespace std;

 

int cycle(intm)

{

   int i = 1;

   while (m != 1){

      if(m%2)

        m = m*3 + 1;

      else

        m /= 2;

      i++;

   }

   return i;

}  

 

int main()

{

   int m,n,max,temp;

   int mOriginal,nOriginal;

   int i;

 

   while (cin >> m >> n){

      mOriginal = m;

      nOriginal = n;

      if (m > n){

        temp = m;

        m = n;

        n = temp;

      }

 

      max = cycle(m);

      for (i = m+1; i <= n; i++){

        temp = cycle(i);

        if (temp > max){

           max = temp;

        }

      } 

      cout << mOriginal << " " << nOriginal << " " << max << endl;

   }

   return 0;

}

Feedback

# re: The 3n + 1 problem  回复  更多评论   

2007-11-14 20:34 by 无意中看到
你这个程序属于很难通过的,基本上会碰到超时问题
输入: 1 1000000
看你多牛的计算机3秒能搞出来
这是典型的dp问题,暴力是不好用的

# re: The 3n + 1 problem  回复  更多评论   

2008-10-18 17:17 by TaiwanNo.1
/*
這個可以以0.7 sec完成
*/
#include <stdio.h>

int compute(int a)
{
int cnt = 1;
while(a > 1)
{
a & 0x01 ? (a = (a<<1) + a + 1) : (a >>= 1);
++cnt;
}
return cnt;
}


int a, b, c;
int i, j;
int main(void)
{

while(0 < scanf("%d %d", &i, &j))
{
c = 0;
i < j ? (a = i, b = j) : (a = j, b = i);
while(a <= b)
{
int tmp = compute(a++);
if(tmp > c)
c = tmp;
}
printf("%d %d %d\n", i, j, c);
}
return 0;
}

# re: The 3n + 1 problem  回复  更多评论   

2011-01-16 13:39 by UDHeart
@TaiwanNo.1
...我就是这样写的,没有这么快

只有注册用户登录后才能发表评论。
网站导航: 博客园   IT新闻   BlogJava   知识库   博问   管理