tctony

Focus on linux,emacs,c/c++,python,algorithm...

  C++博客 :: 首页 :: 新随笔 :: 联系 :: 聚合  :: 管理 ::
  17 随笔 :: 0 文章 :: 7 评论 :: 0 Trackbacks

Write a simple HTML Browser

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 379    Accepted Submission(s): 87


Problem Description
If you ever tried to read a html document on a Macintosh, you know how hard it is if no Netscape is installed.
Now, who can forget to install a HTML browser? This is very easy because most of the times you don't need one on a MAC because there is a Acrobate Reader which is native to MAC. But if you ever need one, what do you do?
Your task is to write a small html-browser. It should only display the content of the input-file and knows only the html commands (tags) <br> which is a linebreak and <hr> which is a horizontal ruler. Then you should treat all tabulators, spaces and newlines as one space and display the resulting text with no more than 80 characters on a line.
 

Input
The input consists of a text you should display. This text consists of words and HTML tags separated by one or more spaces, tabulators or newlines.
A word is a sequence of letters, numbers and punctuation. For example, "abc,123" is one word, but "abc, 123" are two words, namely "abc," and "123". A word is always shorter than 81 characters and does not contain any '<' or '>'. All HTML tags are either <br> or <hr>.
 

Output
You should display the the resulting text using this rules:
  . If you read a word in the input and the resulting line does not get longer than 80 chars, print it, else print it on a new line.
  . If you read a <br> in the input, start a new line.
  . If you read a <hr> in the input, start a new line unless you already are at the beginning of a line, display 80 characters of '-' and start a new line (again).
The last line is ended by a newline character.
 

Sample Input
Hallo, dies ist eine
ziemlich lange Zeile, die in Html
aber nicht umgebrochen wird.
<br>
Zwei <br> <br> produzieren zwei Newlines.
Es gibt auch noch das tag <hr> was einen Trenner darstellt.
Zwei <hr> <hr> produzieren zwei Horizontal Rulers.
Achtung       mehrere Leerzeichen irritieren
Html genauso wenig wie
mehrere Leerzeilen.
 

Sample Output
Hallo, dies ist eine ziemlich lange Zeile, die in Html aber nicht umgebrochen
wird.
Zwei
produzieren zwei Newlines. Es gibt auch noch das tag
--------------------------------------------------------------------------------
was einen Trenner darstellt. Zwei
--------------------------------------------------------------------------------
--------------------------------------------------------------------------------
produzieren zwei Horizontal Rulers. Achtung mehrere Leerzeichen irritieren Html
genauso wenig wie mehrere Leerzeilen.
#include<iostream>
using namespace std;

bool scmp(char a[],char b[]){
    
int i,la=strlen(a),lb=strlen(b);
    
if(la!=lb)    return false;
    
for(i=0;i<la;++i)
        
if(a[i]!=b[i])    return false;
    
return true;
}


int main() {
    
int n=0,len;
    
char s[81];
    
char br[]="<br>";
    
char hr[]="<hr>";
    
    
while(cin>>s){
        len
=strlen(s);
        
if(scmp(s,br)==1){
            cout
<<endl;
            n
=0;
        }

        
else if(scmp(s,hr)){
            
if(n!=0)    {
                cout
<<endl;
                cout
<<"--------------------------------------------------------------------------------"<<endl;
                n
=0;
            }

            
else
                cout
<<"--------------------------------------------------------------------------------"<<endl;
        }

        
else{
            
if((n+len+1)<=80){
                
if(n==0){
                    cout
<<s;
                    n
+=len;
                }

                
else{
                    cout
<<" "<<s;
                    n
+=len+1;
                }

            }

            
else {
                cout
<<endl<<s;
                n
=len;
            }

        }

    }

    cout
<<endl;
    
return 0;
}

。。。。。。。。。比较汗的题。
posted on 2007-11-29 21:59 tctony 阅读(514) 评论(0)  编辑 收藏 引用

只有注册用户登录后才能发表评论。
网站导航: 博客园   IT新闻   BlogJava   知识库   博问   管理