tctony

Focus on linux,emacs,c/c++,python,algorithm...

  C++博客 :: 首页 :: 新随笔 :: 联系 :: 聚合  :: 管理 ::
  17 随笔 :: 0 文章 :: 7 评论 :: 0 Trackbacks

Ignatius's puzzle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 475    Accepted Submission(s): 269


Problem Description
Ignatius is poor at math,he falls across a puzzle problem,so he has no choice but to appeal to Eddy. this problem describes that:f(x)=5*x^13+13*x^5+k*a*x,input a nonegative integer k(k<10000),to find the minimal nonegative integer a,make the arbitrary integer x ,65|f(x)if
no exists that a,then print "no".

 

Input
The input contains several test cases. Each test case consists of a nonegative integer k, More details in the Sample Input.
 

Output
The output contains a string "No",if you can't find a,or you should output a line contains the a.More details in the Sample Output.
 

Sample Input
11
100
9999
 

Sample Output
22
no
43


#include<iostream>
using namespace std;

int main(){
    
int k,i,sum;

    
while(cin>>k){
        
if(k%65==0)    {
            printf(
"no\n");
            
continue;
        }

        
for(i=1;i<66;++i){
            sum
=i*k;    
            
if((sum%65)==47)    break;
        }

        
if(i==66)
            printf(
"no\n");
        
else
            cout
<<i<<endl;
    }

    
return 0;
}

题目的关键是函数式f(x)=5*x^13+13*x^5+k*a*x;
事实上,由于x取任何值都需要能被65整除.那么用数学归纳法.只需找到f(1)成立的a,并在假设f(x)成立的基础上,
证明f(x+1)也成立.
那么把f(x+1)展开,得到5*(  ( 13  0 )x^13 +  (13  1 ) x^12 ...... .....+(13  13) x^0)+13*(  ( 5  0 )x^5+(5  1 )x^4......其实就是二项式展开,这里就省略了  ......+ ( 5  5  )x^0  )+k*a*x+k*a;——————这里的( n  m)表示组合数,相信学过2项式定理的朋友都能看明白.

然后提取出5*x^13+13*x^5+k*a*x
则f(x+1 ) = f (x) +  5*( (13  1 ) x^12 ...... .....+(13  13) x^0  )+  13*(  (5  1 )x^4+...........+ ( 5  5  )x^0  )+k*a;

很容易证明,除了5*(13  13) x^0 、13*( 5  5  )x^0 和k*a三项以外,其余各项都能被65整除.
那么也只要求出18+k*a能被65整除就可以了.
而f(1)也正好等于18+k*a

所以,只要找到a,使得18+k*a能被65整除,也就解决了这个题目.
此题属于纸老虎型^_^(如果没有想到这里就要动用暴力........默哀。)
posted on 2007-11-29 11:06 tctony 阅读(780) 评论(0)  编辑 收藏 引用

只有注册用户登录后才能发表评论。
网站导航: 博客园   IT新闻   BlogJava   知识库   博问   管理