tctony

Focus on linux,emacs,c/c++,python,algorithm...

  C++博客 :: 首页 :: 新随笔 :: 联系 :: 聚合  :: 管理 ::
  17 随笔 :: 0 文章 :: 7 评论 :: 0 Trackbacks

Elevator

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1979    Accepted Submission(s): 1001


Problem Description
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
 

Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.
 

Output
Print the total time on a single line for each test case.
 

Sample Input
1 2
3 2 3 1
0
 

Sample Output
17
41
#include<iostream>
using namespace std;

int move(int c, int n){
    
if(c<n)    return (n-c)*6+5;
    
else return (c-n)*4+5;
}


int main() 
{
    
int n,curfloor,nextfloor,time;
    
while(scanf("%d",&n)){
        
if(n==0)    break;
        time
=curfloor=0;
        
while(n--){
            scanf(
"%d",&nextfloor);
            time
+=move(curfloor,nextfloor);
            curfloor
=nextfloor;
        }

        printf(
"%d\n",time);
    }

    
return 0;
}

简单计算题。
posted on 2007-11-29 08:17 tctony 阅读(440) 评论(0)  编辑 收藏 引用

只有注册用户登录后才能发表评论。
网站导航: 博客园   IT新闻   BlogJava   知识库   博问   管理