acm zoj1090解题报告

Posted on 2010-09-19 22:44 李东亮 阅读(1492) 评论(0)  编辑 收藏 引用
 

The Circumference of the Circle

本题在ZOJ上题号是1090,在POJ上是2242。题目描述如下:

Description

To calculate the circumference of a circle seems to be an easy task - provided you know its diameter. But what if you don't?

You are given the cartesian coordinates of three non-collinear points in the plane.
Your job is to calculate the circumference of the unique circle that intersects all three points.

Input

The input will contain one or more test cases. Each test case consists of one line containing six real numbers x1,y1, x2,y2,x3,y3, representing the coordinates of the three points. The diameter of the circle determined by the three points will never exceed a million. Input is terminated by end of file.

Output

For each test case, print one line containing one real number telling the circumference of the circle determined by the three points. The circumference is to be printed accurately rounded to two decimals. The value of pi is approximately 3.141592653589793.

Sample Input

0.0 -0.5 0.5 0.0 0.0 0.5

0.0 0.0 0.0 1.0 1.0 1.0

5.0 5.0 5.0 7.0 4.0 6.0

0.0 0.0 -1.0 7.0 7.0 7.0

50.0 50.0 50.0 70.0 40.0 60.0

0.0 0.0 10.0 0.0 20.0 1.0

0.0 -500000.0 500000.0 0.0 0.0 500000.0

Sample Output

3.14

4.44

6.28

31.42

62.83

632.24

3141592.65

分析:本题是一道比较容易的题,具体就考察了几个数学公式的使用。本题的关键是求出内接三角形的外接圆直径。而在圆的内接三角形的性质中有这样一条:三角形的任何两边的乘积的等于第三边上的高于其外接圆直径的乘积。这样问题就转化为求接三角形的某一边上的高,在知道三角形三个顶点的情况下,求其面积应该是件容易事,求得面积后,高的问题也就迎刃而解。求面积时,由于本人较懒,用的是海伦公式:S = ,其中p = (a+b+c)/2abc分别为三角形的三个变长,S=0.5*c*h,即可求得ha*b=h*d,那么直径d也就出来了。具体代码如下.

#include <stdio.h>

#include <stdlib.h>

#include <math.h>

int main(void)

{

       double x1, y1, x2, y2, x3, y3;

       double l1, l2, l3;

       double p;

       double h;

       double d;

       while (scanf("%lf%lf%lf%lf%lf%lf", &x1, &y1, &x2, &y2, &x3, &y3) == 6)

       {

              l1 = sqrt(pow(x1-x2, 2) + pow(y1-y2, 2));

              l2 = sqrt(pow(x1-x3, 2) + pow(y1-y3, 2));

              l3 = sqrt(pow(x2-x3, 2) + pow(y2-y3, 2));

              p = (l1 + l2 + l3)/2;

              h = sqrt(p*(p-l1)*(p-l2)*(p-l3))*2/l3;

              d = l1*l2/h;

              printf("%.2f\n", 3.141592653589793*d);

       }

       return 0;

}


只有注册用户登录后才能发表评论。
网站导航: 博客园   IT新闻   BlogJava   知识库   博问   管理


posts - 12, comments - 1, trackbacks - 0, articles - 1

Copyright © 李东亮