Welcome to Leon's Blog  
日历
<2008年6月>
25262728293031
1234567
891011121314
15161718192021
22232425262728
293012345
统计
  • 随笔 - 30
  • 文章 - 0
  • 评论 - 51
  • 引用 - 0

导航

常用链接

留言簿(4)

随笔分类

随笔档案

ACM

搜索

  •  

最新评论

阅读排行榜

评论排行榜

 
     今天做完1006题,第一次用枚举法,但是时间复杂度大,后来看到帖子说是用中国余数法。自己试着也写了一个,但是用时也过大,现在把代码贴出来,请大家帮忙改一改啊!谢谢了!
 1#include <stdio.h>
 2
 3int main(int argc, char* argv[])
 4{
 5    int p,e,i,d, index;
 6    int day;
 7    int x = 28*33*6;
 8    int y = 23*33*19;
 9    int z = 23*28*2;
10    index = 0;
11    
12
13    do
14    {
15        scanf("%d %d %d %d"&p,&e, &i, &d);
16        if(p == -1 && e == -1 && i == -1 && d == -1)
17            break;
18        p = p%23;
19        e = e%28;
20        i = i%33;
21        day = (p*+ e*+ i*z) % 21252;
22        if(day == d)
23            day += 21252;
24        printf("Case %d: the next triple peak occurs in %d days.\n"++index,day->= 0 ? day-d : day-d+21252);
25    }
while(1); 
26    return 0;
27}
posted on 2008-05-30 20:43 Leon916 阅读(1209) 评论(4)  编辑 收藏 引用
评论:
  • # re: 1006求助  夜弓 Posted @ 2008-05-31 07:21
    /*
    Description
    Some people believe that there are three cycles in a person's life that start the day he or she is born. These three cycles are the physical, emotional, and intellectual cycles, and they have periods of lengths 23, 28, and 33 days, respectively. There is one peak in each period of a cycle. At the peak of a cycle, a person performs at his or her best in the corresponding field (physical, emotional or mental). For example, if it is the mental curve, thought processes will be sharper and concentration will be easier.
    Since the three cycles have different periods, the peaks of the three cycles generally occur at different times. We would like to determine when a triple peak occurs (the peaks of all three cycles occur in the same day) for any person. For each cycle, you will be given the number of days from the beginning of the current year at which one of its peaks (not necessarily the first) occurs. You will also be given a date expressed as the number of days from the beginning of the current year. You task is to determine the number of days from the given date to the next triple peak. The given date is not counted. For example, if the given date is 10 and the next triple peak occurs on day 12, the answer is 2, not 3. If a triple peak occurs on the given date, you should give the number of days to the next occurrence of a triple peak.

    Input
    You will be given a number of cases. The input for each case consists of one line of four integers p, e, i, and d. The values p, e, and i are the number of days from the beginning of the current year at which the physical, emotional, and intellectual cycles peak, respectively. The value d is the given date and may be smaller than any of p, e, or i. All values are non-negative and at most 365, and you may assume that a triple peak will occur within 21252 days of the given date. The end of input is indicated by a line in which p = e = i = d = -1.

    Output
    For each test case, print the case number followed by a message indicating the number of days to the next triple peak, in the form:

    Case 1: the next triple peak occurs in 1234 days.

    Use the plural form ``days'' even if the answer is 1.

    Sample Input

    0 0 0 0
    0 0 0 100
    5 20 34 325
    4 5 6 7
    283 102 23 320
    203 301 203 40
    -1 -1 -1 -1

    Sample Output

    Case 1: the next triple peak occurs in 21252 days.
    Case 2: the next triple peak occurs in 21152 days.
    Case 3: the next triple peak occurs in 19575 days.
    Case 4: the next triple peak occurs in 16994 days.
    Case 5: the next triple peak occurs in 8910 days.
    Case 6: the next triple peak occurs in 10789 days.*/
    #include <cstdio>

    int main()
    {
    int x,y,z,s,t;
    size_t i(0);
    scanf("%d %d %d %d", &x, &y, &z, &s);
    while(x!=-1 || y!=-1 || z!=-1 || s!=-1){
    t = (5544*x + 14421*y + 1288*z) % 21252;
    t -= s;
    if(t<=0)
    t+=21252;
    printf("Case %d: the next triple peak occurs in %d days.\n",
    ++i,t);
    scanf("%d %d %d %d", &x, &y, &z, &s);
    }
    }
      回复  更多评论   

  • # re: 1006求助  夜弓 Posted @ 2008-05-31 07:31
    感觉没多大区别,我的比你少取了点模
    40K 75MS
    至于哪些超快的,我觉得可能是这个原因:
    那句printf应该改成sprintf,先到缓冲区,最后再输出~
    不过就算这样能提高成绩,我觉得其实意义也不大~  回复  更多评论   

  • # re: 1006求助  郴州SEO Posted @ 2008-06-01 07:34
    有点晕...  回复  更多评论   

  • # re: 1006求助  Leon916 Posted @ 2008-06-01 11:34
    哦,我在网上看到,有些人写的程序时间和空间都很少,真不知道是怎么写出来的  回复  更多评论   


只有注册用户登录后才能发表评论。
网站导航: 博客园   IT新闻   BlogJava   知识库   博问   管理


 
Copyright © Leon916 Powered by: 博客园 模板提供:沪江博客