Problem description

Now an emergent task for you is to open a password lock. The password is consisted of four digits. Each digit is numbered from 1 to 9.
Each time, you can add or minus 1 to any digit. When add 1 to '9', the digit will change to be '1' and when minus 1 to '1', the digit will change to be '9'. You can also exchange the digit with its neighbor. Each action will take one step.

Now your task is to use minimal steps to open the lock.

Note: The leftmost digit is not the neighbor of the rightmost digit.


 
Input
The input file begins with an integer T, indicating the number of test cases.

Each test case begins with a four digit N, indicating the initial state of the password lock. Then followed a line with anotther four dight M, indicating the password which can open the lock. There is one blank line after each test case.


 
Output
For each test case, print the minimal steps in one line.


Sample Input
2
1234
2144

1111
9999
 
Sample Output
2
4




广度搜索:

  1 #include  < iostream >
  2 #include  < queue >
  3 #include  < algorithm >
  4
  5 using   namespace  std;
  6
  7 bool   mark[ 10000 ];
  8
  9 struct  Node
 10 {
 11      int    step;
 12      char   state[ 5 ];
 13
 14     Node()
 15      {}
 16
 17     Node(  int  i,  char *  str )
 18         :step(i)
 19      {
 20         strcpy( state, str );
 21     }

 22 }
;
 23
 24
 25 int  getn(  char  str[ 5 ] )
 26 {
 27      return  (str[ 0 ] -   ' 0 ' ) *   1000 +  ( str[ 1 ] -   ' 0 '  ) *   100 +  ( str[ 2 ] -   ' 0 '  ) *   10 +  (str[ 3 ] -   ' 0 '  );
 28 }

 29
 30
 31 int  main()
 32 {
 33      char     initial[ 5 ];
 34      char     open[ 5 ];
 35      int      Cases;
 36
 37     scanf( " %d " , & Cases);
 38      while  ( Cases --  )
 39      {
 40         memset( mark,  false sizeof (mark) );
 41
 42         queue < struct  Node >   q;
 43         scanf( " %s%s " ,initial,open);
 44
 45         q.push ( Node( 0 ,initial) );
 46         mark[ getn(initial) ] =   true ;
 47
 48          while  (  ! q.empty () )
 49          {
 50              struct  Node head =  q.front ();
 51             q.pop ();
 52
 53              if  ( strcmp( head.state , open) ==   0  )
 54              {
 55                 printf( " %d " ,head.step );
 56                  break ;
 57             }

 58
 59              for  (  int  i =   0 ; i <   3 ++ i )
 60              {        
 61                  char  temp[ 5 ];
 62                 strcpy( temp, head.state );
 63
 64                 std::swap ( temp[i], temp[i + 1 ] );
 65                  if  (  ! mark[ getn(temp) ] )
 66                  {
 67                     q.push ( Node(head.step +   1 , temp ) );
 68                     mark[ getn(temp) ] =   true ;
 69                 }

 70             }

 71
 72              for  (  int  i =   0 ; i <   4 ++ i )
 73              {
 74                  char  temp[ 5 ];
 75                 strcpy( temp, head.state );
 76
 77                  if  ( temp[i] ==   ' 9 '  ) temp[i] =   ' 1 ' ;
 78                  else  temp[i] =  temp[i] +   1 ;
 79
 80                  int  n =  getn(temp);
 81                  if  (  ! mark[n] )
 82                  {
 83                     q.push ( Node( head.step +   1 , temp ) );
 84                     mark[n] =   true ;
 85                 }

 86             }

 87
 88              for  (  int  i =   0 ; i <   4 ++ i )
 89              {
 90                  char  temp[ 5 ];
 91                 strcpy( temp, head.state );
 92
 93                  if  ( temp[i] ==   ' 1 '  ) temp[i] =   ' 9 ' ;
 94                  else  temp[i] =  temp[i] -   1 ;
 95
 96                  int  n =  getn(temp);
 97                  if  (  ! mark[n] )
 98                  {
 99                     q.push ( Node( head.step +   1 , temp ) );
100                     mark[n] =   true ;
101                 }

102             }

103         }

104
105          if  ( Cases ) printf( " \n " );
106     }

107
108      return   0 ;
109 }

110
posted on 2008-08-19 16:38 Darren 阅读(374) 评论(0)  编辑 收藏 引用 所属分类: 搜索

只有注册用户登录后才能发表评论。
网站导航: 博客园   IT新闻   BlogJava   知识库   博问   管理