无声的月

 

POJ 1459 最大流 Edmonds-Karp算法

Power Network
Time Limit: 2000MS Memory Limit: 32768K
Total Submissions: 10383 Accepted: 5691

Description

A power network consists of nodes (power stations, consumers and dispatchers) connected by power transport lines. A node u may be supplied with an amount s(u) >= 0 of power, may produce an amount 0 <= p(u) <= pmax(u) of power, may consume an amount 0 <= c(u) <= min(s(u),cmax(u)) of power, and may deliver an amount d(u)=s(u)+p(u)-c(u) of power. The following restrictions apply: c(u)=0 for any power station, p(u)=0 for any consumer, and p(u)=c(u)=0 for any dispatcher. There is at most one power transport line (u,v) from a node u to a node v in the net; it transports an amount 0 <= l(u,v) <= lmax(u,v) of power delivered by u to v. Let Con=Σuc(u) be the power consumed in the net. The problem is to compute the maximum value of Con.

An example is in figure 1. The label x/y of power station u shows that p(u)=x and pmax(u)=y. The label x/y of consumer u shows that c(u)=x and cmax(u)=y. The label x/y of power transport line (u,v) shows that l(u,v)=x and lmax(u,v)=y. The power consumed is Con=6. Notice that there are other possible states of the network but the value of Con cannot exceed 6.

Input

There are several data sets in the input. Each data set encodes a power network. It starts with four integers: 0 <= n <= 100 (nodes), 0 <= np <= n (power stations), 0 <= nc <= n (consumers), and 0 <= m <= n^2 (power transport lines). Follow m data triplets (u,v)z, where u and v are node identifiers (starting from 0) and 0 <= z <= 1000 is the value of lmax(u,v). Follow np doublets (u)z, where u is the identifier of a power station and 0 <= z <= 10000 is the value of pmax(u). The data set ends with nc doublets (u)z, where u is the identifier of a consumer and 0 <= z <= 10000 is the value of cmax(u). All input numbers are integers. Except the (u,v)z triplets and the (u)z doublets, which do not contain white spaces, white spaces can occur freely in input. Input data terminate with an end of file and are correct.

Output

For each data set from the input, the program prints on the standard output the maximum amount of power that can be consumed in the corresponding network. Each result has an integral value and is printed from the beginning of a separate line.

Sample Input

2 1 1 2 (0,1)20 (1,0)10 (0)15 (1)20
7 2 3 13 (0,0)1 (0,1)2 (0,2)5 (1,0)1 (1,2)8 (2,3)1 (2,4)7
(3,5)2 (3,6)5 (4,2)7 (4,3)5 (4,5)1 (6,0)5
(0)5 (1)2 (3)2 (4)1 (5)4

Sample Output

15
6

Hint

The sample input contains two data sets. The first data set encodes a network with 2 nodes, power station 0 with pmax(0)=15 and consumer 1 with cmax(1)=20, and 2 power transport lines with lmax(0,1)=20 and lmax(1,0)=10. The maximum value of Con is 15. The second data set encodes the network from figure 1.

Source

 1 #include<iostream>
 2 #include<queue>
 3 #include<algorithm>
 4 #include<string>
 5 #include<cstdlib>
 6 using namespace std;
 7 const int M=105;
 8 const int INF=1000000;
 9 int cap[M][M],flow[M][M],p[M],a[M];
10 int n,np,nc,m,s,t,i,j,k,u,v,w,ans;
11 queue<int> q;
12 char str[100];
13 int main()
14 {
15     while(cin>>n>>np>>nc>>m)
16     {
17         memset(flow,0,sizeof(flow));
18         memset(cap,0,sizeof(cap));
19         ans=0;
20         s=n;
21         t=n+1;
22         
23         for(i=0;i<m;i++)
24         {
25             scanf("%s",str);
26             sscanf(str,"(%d,%d)%d",&u,&v,&w);
27             cap[u][v]=w;
28         }
29         for(i=0;i<np;i++)
30         {
31             scanf("%s",str);
32             sscanf(str,"(%d)%d",&v,&w);
33             cap[s][v]=w;
34         }
35         for(i=0;i<nc;i++)
36         {
37             scanf("%s",str);
38             sscanf(str,"(%d)%d",&u,&w);
39             cap[u][t]=w;
40         }
41         while(true)
42         {
43             memset(a,0,sizeof(a));
44             a[s]=INF;
45             q.push(s);
46             while(!q.empty())
47             {
48                 u=q.front();
49                 q.pop();
50                 for(v=0;v<=t;v++)
51                 {
52                     if(!a[v]&&cap[u][v]>flow[u][v])
53                     {
54                         p[v]=u;
55                         q.push(v);
56                         a[v]=min(a[u],cap[u][v]-flow[u][v]);
57                     }
58                 }
59             }
60                 
61             if(a[t]==0)
62             {
63                 break;
64             }
65                 
66             for(u=t;u!=s;u=p[u])
67             {
68                 flow[p[u]][u]+=a[t];
69                 flow[u][p[u]]-=a[t];
70             }
71             ans+=a[t];
72         }
73         cout<<ans<<endl;
74     }
75 }
76             
77 
78 
79 

Coming from:http://hi.baidu.com/%8E%E1%D0%B3/blog/item/6fddc4c9c56ff512be09e635.html

posted on 2010-07-21 10:55 Baron 阅读(341) 评论(0)  编辑 收藏 引用


只有注册用户登录后才能发表评论。
网站导航: 博客园   IT新闻   BlogJava   知识库   博问   管理


导航

统计

常用链接

留言簿

随笔分类

随笔档案

文章分类

文章档案

搜索

最新评论

阅读排行榜

评论排行榜