付翔的专栏
在鄙视中成长 记录成长的点滴
posts - 106,  comments - 32,  trackbacks - 0

Function Run Fun
Time Limit: 1000MS  Memory Limit: 10000K
Total Submissions: 6420  Accepted: 3526

Description

We all love recursion! Don't we?

Consider a three-parameter recursive function w(a, b, c):

if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns:
1

if a > 20 or b > 20 or c > 20, then w(a, b, c) returns:
w(20, 20, 20)

if a < b and b < c, then w(a, b, c) returns:
w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c)

otherwise it returns:
w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1)

This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion.

Input

The input for your program will be a series of integer triples, one per line, until the end-of-file flag of -1 -1 -1. Using the above technique, you are to calculate w(a, b, c) efficiently and print the result.
Output

Print the value for w(a,b,c) for each triple.
Sample Input

1 1 1
2 2 2
10 4 6
50 50 50
-1 7 18
-1 -1 -1
Sample Output

w(1, 1, 1) = 2
w(2, 2, 2) = 4
w(10, 4, 6) = 523
w(50, 50, 50) = 1048576
w(-1, 7, 18) = 1

 

#include<stdio.h>
long data[21][21][21= {0};
int fun(int a,int b,int c)//根据题意来写函数
{
if(a<=0||b<=0||c<=0)
return 1;
else if(a>20||b>20||c>20)
return fun(20,20,20);
if(data[a][b][c])//要是 data已经存在的话就直接返回值
return data[a][b][c];
else if(a<b&&b<c)
return fun(a, b, c-1+ fun(a, b-1, c-1- fun(a, b-1, c);
else
return fun(a-1, b, c) + fun(a-1, b-1, c) + fun(a-1, b, c-1- fun(a-1, b-1, c-1);
}

int main()
{
int a, b ,c;//三维
data[0][0][0= 1;
for(a = 0;a<=20;a++)
for(b = 0;b<=20; b++)
for(c = 0;c <=20; c ++)
{
data[a][b][c] 
= fun(a,b,c);
}

while(scanf("%d%d%d",&a,&b,&c)!=EOF)
{
if(a==-1&&b==-1&&c==-1)
return 1;
printf(
"w(%d, %d, %d) = %d\n",a,b,c,fun(a,b,c));
}

return 0;
}


 

posted on 2009-08-06 21:00 付翔 阅读(848) 评论(0)  编辑 收藏 引用

只有注册用户登录后才能发表评论。
网站导航: 博客园   IT新闻   BlogJava   知识库   博问   管理



<2009年8月>
2627282930311
2345678
9101112131415
16171819202122
23242526272829
303112345

常用链接

留言簿(2)

随笔分类

随笔档案

文章分类

文章档案

CSDN - 我的blog地址

博客

搜索

  •  

最新评论

阅读排行榜

评论排行榜