Lost Cows

Description

N (2 <= N <= 8,000) cows have unique brands in the range 1..N. In a spectacular display of poor judgment, they visited the neighborhood 'watering hole' and drank a few too many beers before dinner. When it was time to line up for their evening meal, they did not line up in the required ascending numerical order of their brands.

Regrettably, FJ does not have a way to sort them. Furthermore, he's not very good at observing problems. Instead of writing down each cow's brand, he determined a rather silly statistic: For each cow in line, he knows the number of cows that precede that cow in line that do, in fact, have smaller brands than that cow.

Given this data, tell FJ the exact ordering of the cows.

Input

* Line 1: A single integer, N

* Lines 2..N: These N-1 lines describe the number of cows that precede a given cow in line and have brands smaller than that cow. Of course, no cows precede the first cow in line, so she is not listed. Line 2 of the input describes the number of preceding cows whose brands are smaller than the cow in slot #2; line 3 describes the number of preceding cows whose brands are smaller than the cow in slot #3; and so on.

Output

* Lines 1..N: Each of the N lines of output tells the brand of a cow in line. Line #1 of the output tells the brand of the first cow in line; line 2 tells the brand of the second cow; and so on.

Sample Input

5
1
2
1
0

Sample Output

2
4
5
#include<stdio.h>
#define maxn 8000
int tree[maxn*3], s[maxn], ans[maxn];
void build(int l, int r, int depth)
{
    tree[depth] 
= r - l + 1;
    
if (l != r)
    {
        
int mid = (l + r) >> 1;
        build(l, mid, (depth 
<< 1));
        build(mid 
+ 1, r, (depth << 1+ 1);
    }
}
void find(int l, int r, int index, int num, int depth)
{
    tree[depth]
--;
    
if (l == r)
    {
        ans[index] 
= r;
        
return;
    }
    
else
    {
        
int mid = (l + r) >> 1, m = depth << 1;
        
if (num <= tree[m])
        {
            find(l, mid, index, num, m);
        }
        
else
        {
            num 
-= tree[m];
            find(mid 
+ 1, r, index, num, m + 1);
        }
    }
}
int main()
{
    
int n, i;
    
while (scanf("%d"&n) != EOF)
    {
        build(
1, n, 1);
        
for (i = 2, s[1= 1; i <= n; i++)
        {
            scanf(
"%d"&s[i]);
            s[i]
++;
        }
        
for (i = n; i >= 1; i--)
        {
            find(
1, n, i, s[i], 1);
        }
        
for (i = 1; i <= n; i++)
        {
            printf(
"%d\n", ans[i]);
        }
    }
    
return 0;
}

3
1
题意:给出每个数所在位置的逆序列个数,求这些数。
用线段树写,一来统计个数,而来可以随时删除已去掉的数,这些操作都是logn。