Bad Hair Day

Description

Some of Farmer John's N cows (1 ≤ N ≤ 80,000) are having a bad hair day! Since each cow is self-conscious about her messy hairstyle, FJ wants to count the number of other cows that can see the top of other cows' heads.

Each cow i has a specified height hi (1 ≤ hi ≤ 1,000,000,000) and is standing in a line of cows all facing east (to the right in our diagrams). Therefore, cow i can see the tops of the heads of cows in front of her (namely cows i+1, i+2, and so on), for as long as these cows are strictly shorter than cow i.

Consider this example:

        =
=       =
=   -   =         Cows facing right -->
=   =   =
= - = = =
= = = = = =
1 2 3 4 5 6

Cow#1 can see the hairstyle of cows #2, 3, 4
Cow#2 can see no cow's hairstyle
Cow#3 can see the hairstyle of cow #4
Cow#4 can see no cow's hairstyle
Cow#5 can see the hairstyle of cow 6
Cow#6 can see no cows at all!

Let ci denote the number of cows whose hairstyle is visible from cow i; please compute the sum of c1 through cN.For this example, the desired is answer 3 + 0 + 1 + 0 + 1 + 0 = 5.

Input

Line 1: The number of cows, N.
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i.

Output

Line 1: A single integer that is the sum of c1 through cN.

Sample Input

6
10
3
7
4
12
2

Sample Output

5
题意:
给出的序列中,如果i < k < j 而且 h[k] < h[i] < h[j],对i找出i到j区间比h[i]小的数的个数s[i]。然后对每个i求和。
#include<stdio.h>
#define maxn 80001
int h[maxn], next[maxn], s[maxn];
int main()
{
    
int i, k, n;
    unsigned sum;
    
while (scanf("%d"&n) != EOF)
    {
        
for (i = 0; i < n; i++)
        {
            scanf(
"%d"&h[i]);
            s[i] 
= 0;
        }
        
for (i = n - 1, sum = 0; i >= 0; i--)
        {
            k 
= i + 1;
            
for (; k < n && h[k] < h[i]; k = next[k])//每一次都把寻找比h[i]大的h[k]。
            {
                s[i] 
+= s[k] + 1;
            }
            next[i] 
= k;
            sum 
+= s[i];
        }
        printf(
"%u\n", sum);
    }
    
return 0;
}